Search Results: "wagner"

29 November 2009

Jan Wagner: [selfnote] Change CD-image while (HVM) domU is running

xm list grep <VMName>
xm block-list <VMName_Number>
xm block-detach <VMName_Number> <VMName_Vdev> -f
xm block-attach <VMName_Number> file:///iso/disk.iso \
hdc:cdrom r

18 November 2009

Jan Wagner: dkms rocks or how to get the Intel 82576 GBit NIC running on Lenny

We ordered a couple of the new HP DL160 G6, cause they can be equipped with a lot of RAM. Unfortunately it s always the same with HP and the bandnew ProLiant 100 series the driver for the NICs is missing/too old in the latest stable debian release. The DL160 G6 is shipped with a Intel 82576 GBit NIC, which isn t recognized by Lenny, see also #522922.
I installed the system with another NIC installed (not really, but this is a way it works :) and wanted to get free the PCI-X slot again. So I did backport dkms and downloaded the latest igb driver. A short look into /usr/share/doc/dkms/HOWTO.Debian did advice me the way to create the DKMS driver package. Just after a couple of minutes I did roll out the igb-dkms_2.0.6_all.deb to the target maschine(s).
On the target systems I just installed dkms, the DKMS package and appropriate linux-headers and sim, salabim there was the interfaces. :)

25 October 2009

Jan Wagner: OpenWRT WDS works like charm

A try with OpenWRT 8.09 in April to setup a WDS with additional AP functionality and encryption, like described in the documentation, failed. So I keeped with my halfbroken solution running on DD-WRT, which is going a bit too commercial these days in my eyes.
Now I have found time to try OpenWRT again for this purpose, since the issue was fixed really fast. I just did setup a stock 8.09.1 installation and then dropped the following into /etc/config/wireless:

config wifi-device wl0
option type broadcom
option channel 5
option disabled 0
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid OpenWrt
option encryption psk2
option key keyforclients
config wifi-iface
option device wl0
option network lan
option mode wds
option bssid 00:16:B6:19:63:C8
option ssid OpenWrtWDS
option encryption psk2
option key pskforWDS And guess what? It worked like a charm! So I could replace the odd DD-WRT boxes. Anyways ... does anybody have an idea where to find the sourcecode of anything > v23 SP1?

18 September 2009

Jan Wagner: Cloning/Backing up NTFS systems

For some reasons, you may need to clone/backup NTFS based systems. Lets say your NTFS system is located at /dev/sda1 and /dev/sdb1 is a spare partition where you can store your image. At first you need to boot a live system to take an image:

mount /dev/sdb1 /mnt/sdb1
dd bs=512 count=1 if=/dev/sda of=/mnt/sdb1/xp_vbox.mbr
ntfsclone -s -o /dev/sda1 bzip2 -9 -c > \
/mnt/sdb1/xp_vbox.img.bz2 To restore the image you just need:

mount /dev/sdb1 /mnt/sdb1
dd count=1 bs=446 if=/mnt/sdb1/xp_vbox.mbr of=/dev/sda
cat /mnt/sdb1/xp_vbox.img.bz2 bunzip2 -c \
ntfsclone -r -O /dev/sda1 - P.S. If you are elective in germany, have a look at this!

24 May 2009

Jan Wagner: [vacation] 30/05/09 - 14/06/09 Manerba del Garda

I m on vacation the 1rst two weeks of June in Manerba del Garda at Lago di Garda. If some dudes are around for beering / chatting / keysigning, feel free to contact me til Friday.
In case of urgent actions (for example #530271), I m without regular internet access there. Feel free to NMU if needed, but try to avoid breaking things. For secuirty related issues please coordinate with team@security.debian.org.
Since I m probably most of the rest of the week busy with organising our camping, please send a short ping, if I m not responding by time, please go ahead.

02 April 2009

Jan Wagner: The Crisis of Credit Visualized


The Crisis of Credit Visualized from Jonathan Jarvis on Vimeo.

15 February 2009

Jan Wagner: Oh happy day

What a happy day on the wedding anniversary of our civil marriage we got a great gift. Our favorite distribution released a new major version.
Like every time it s the best distribution our project released so far. Many thanks to all those people who did make that happen. If you not married today, maybe you have the possibility to dedicate Lenny to your valentine. :)

13 November 2008

Jan Wagner: pulled out for nothing

Dear Stefan ‘Frost’ Mueller, it was a great pleasure to know you. I’m really shocked, that such a nice and young man was pulled out of life out of the blue. Thanks for all the great things you have done for my family and me. Nothing more I can say at the moment other than ‘I hope we will see us again anytime wherever’.

19 September 2008

Jan Wagner: Migrating Mails from Dovecot to Cyrus what a pain!

Today I had to move an Inbox of some Gig mail to transfer from a dovecot to a cyrus imap server. I thought using imapsync would just do the trick, but no it doesn’t. Many of the messages wasn’t transferable cause “Message contains invalid header”.
I tried to upgrade imapsync, dovecot and cyrus to the latest version, but nothing fixed the problem. Digging around in the ned did lead me after hours to Renes
How to fix emails for Cyrus LMTP and IMAP
. I did throw his script on the Inbox of the dovecot server, but this did lead me into getting “FETCH for mailbox got too little data” in the dovecot server log and breaking down the connection of the imap client to the server. This could be fixed while removing corresponding dovecot.index.cache and restarting the server.

16 September 2008

Jan Wagner: Thanks

To make it short: many thanks to wouter, myon, weasel and especially santiago and panthera … you made my month, definetly!

09 September 2008

Jan Wagner: life

28 July 2008

Jan Wagner: [vacation] off until the weekend

After a hard week at work I’m just off for vacation until the weekend without network access. If there are urgent steps needed with my packages, just feel free for a 0day NMU.

26 July 2008

Philipp Kern: Stable Point Release: Etch 4.0r4 (aka etchnhalf)

Another point release for Etch has been done; now it's the time for the CD team to roll out new images after the next mirror pulse. The official announcements (prepared by Alexander Reichle-Schmehl, thanks!) will follow shortly afterwards. FTP master of the day was Joerg Jaspert, who did his first point release since Woody, as he told us on IRC. We appreciate your work and you spending your time that shortly before going to Argentina. This point release includes the etchnhalf update introducing a new kernel image (based on 2.6.24) and some driver updates. Additionally the infamous openssl hole will be fixed for good, even for new installs. Again I want to present you a list of people who contributed to this release. It cannot be complete as I got the information out of the Changed-by fields of the uploads. From the Release Team we had dann frazier (who drove the important kernel part of etchnhalf), Luk Claes, Neil McGovern, Andreas Barth, Martin Zobel-Helas and me working on it. ;-)

22 July 2008

Jan Wagner: Alien 2.0 released

In case you missed it, alien 2.0 was final released (5 weeks ago).
alien alien2

02 July 2008

Jan Wagner: Bayreuth Festival - Online streaming of Die Meistersinger von N rnberg

Actual I’m involved into a project which maybe of interest for you if you like opera particular when you are a Richard Wagner enthusiast.
Since long time, the waiting period for obtaining tickets increases a lot. At the moment I think you have to wait around 8 years, which is a worse.
Time changes also at Bayreuth Festival, they seems to refocus their audience. Looks like the aspects of huge waiting list and new medias influenced that process. This year the opera “Die Meistersinger” is broadcasted online under the slogan “live dabei” (live there) via the great thing called “Internet” and to a public viewing area in Bayreuth, which is a premiere in both cases. So if you don’t have a ticket for the Festspielhaus and not in a position to make use of the public viewing but interested to have a look at the opera, you may want to check if your system matches the technical requirements and give it a try.

14 June 2008

Jan Wagner: postfwd 1.10pre7c-1 in experimental

postfwd 1.10pre7c-1 has been accepted and did hit experimental yesterday.
If you using policyd-weight you might want to give it a try, since its active development stoped. If you are annoyed by too much spam, it maybe a good idea as well.
Please have a look on postfwd.cf, there is no default config provided, since the configuration depends heavily on your environment. But maybe you have a look at /usr/share/doc/postfwd/examples, there is what you expect.
If you have any comments, send a mail to the maintainer or if there are bugs I didn’t spotted yet, please fill one!
In case I don’t respond quit fast, maybe I’m in the delivery room or anywhere else in the hospital or something like that, so please give me some extra time.
In case there are no big issues, I plan to upload the package to unstable in a reasonable time.

23 May 2008

Jan Wagner: Kabel Deutschland breaks DNS System for it s customers

Last week I noticed, that Kabel Deutschland, a cable provider in germany, returns for any non existing hosts “204.9.89.60″. It seems, thats it is rolled out since last fall. Even for DNSSEC enabled infrastructure it breaks it totally:

; <<>> DiG 9.3.4 <<>> +dnssec web.pixaco.se @83.169.184.161
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; ANSWER SECTION:
web.pixaco.se. 0 IN A 204.9.89.60 Beside that, this behavour breaks the whole DNS, since many mechanism rely on a negative answer. The most visible effect for the users is, that when having a typo on surfing, he will forwarded to http://suche.kabeldeutschland.de/de.kde.assist/?domain=<domainyoutypedinyourprompt>. Since 204.9.88.0/21 is located at our transatlantic friends from US, there might be some problem with leaking privacy informations. I don’t feel happy, if I had a typo in my URL and getting listed for it on any terror list or providing the newest porno links to my american friends inside the organisations with the tree capitals. All that for getting some extra money, but racing pricedumping for connectivity, this sucks a lot.
If you are a customer and feel pissed, you can send a friendly note to them:

Kabel Deutschland Vertrieb und Service GmbH & Co. KG
Beschwerdestelle
99116 Erfurt
kundenservice@kabeldeutschland.de
Fax: 01805299925
A quick and dirty workaround for dnsmasq maybe to add “bogus-nxdomain=204.9.89.60″ to your config file. This doesn’t fix the DNSSEC problem.
The problem also pops up at dns-operations and there are traces at google too.

20 May 2008

Jan Wagner: (old) L-root DNS Server stolen (for a short time)

After shutdown of the old L.ROOT-SERVERS.NET the IP address formerly associated with it, the IP continued to answere requests. More informations can be found at the ICANN Blog
UPDATE: Before bothering around, if you read the ICANN Blog, you realize that the issue was fixed very shortly. The whole problem is, that the file of the root DNS servers have to be keeped up to date. This issue should be fixed by operator of resolving nameservers (usually your ISP). A goody will be, to have this fixed by the next point release of debian, but it is NOT security critical.
Thanks Thijs for make me sensible that my article may misslead people who are not reading the referenced document.
UPDATE 2: A more technical description can also be found at Renesys Blog and a disussion how it is related to debian.

26 April 2008

Jan Wagner: off for vacation

I’m off for vacation for just a week without any internet access (Oh my good, I will hate my inbox). This break will give me some time for my wife and my daughter before my second daughter will arrive in this world which is scheduled for mid june.
If there anything strange happen with my packages, just feel free for a 0day NMU.
Just after this week, I will attend to RIPE 56 where my latency will just a bit lower than normal.

25 April 2008

Jan Wagner: security: wordpress 2.5.1 which fixes CVE-2008-1930

Cause the subject, I did build a new package which can be installed on etch, lenny and of course sid. You can fetch it from http://ftp.cyconet.org/debian/archive/bpo/wordpress/2.5.1-1~bpo40+1/ or get via

deb http://ftp.cyconet.org/debian etch-backports main non-free contrib Selfnote: Dump the wordpress user into separate domU

Next.

Previous.